USE1 ezyVet Performance Issue

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Nov 10, 2025 - 13:24 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 10, 2025 - 13:11 EST

Investigating

Our technical team are currently investigating reports of degraded performance occurring with ezyVet in the **USE1** region

We apologize for the inconvenience this is causing – we will provide an update as soon as we have more information.
Posted Nov 10, 2025 - 12:43 EST
This incident affected: ezyVet Software (ezyVet Software: USA and Canada Central/East).