SmartFlow Partial Service Outage

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Nov 06, 2025 - 12:32 EST

Investigating

We're currently experiencing degraded performance with SmartFlow. Our team is currently working to restore normal performance. We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Nov 06, 2025 - 04:19 EST
This incident affected: SmartFlow (iPad, Web).