Delays in some data being updated in Vello to USW2 ezyVet sites

Incident Report for IDEXX Software

Resolved

This issue should now be resolved.
Posted Sep 21, 2026 - 16:54 EDT

Investigating

Customers based in the us-west-2 region may be experiencing a delay in data being updated in Vello.

We're actively investigating the issue and will provide an update shortly.
Posted Sep 21, 2026 - 16:38 EDT
This incident affected: Vello (ezyVet Vello).