DVMI - Sending DICOM images to DVMI

Incident Report for IDEXX Software

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 20, 2026 - 16:27 EDT

Identified

We have identified a known issue with DVMI and the ability to DICOM send. Our technical team is underway with a resolution and will be making updates to the application.
Posted Apr 20, 2026 - 14:58 EDT
This incident affects: Telemedicine (DVMInsight).