ezyVet Performance Issue USW2
Incident Report for IDEXX Software
Resolved
This issue has been resolved and the monitoring period has successfully passed. All systems are back to operational levels and functioning as expected.

Thank you for your patience as we worked through resolving this issue.
Posted Oct 10, 2024 - 20:59 EDT
Monitoring
Our technical team have applied a fix to resolve this issue.

We will be monitoring this for the next 15 minutes to ensure the system is completely stabilized.
Posted Oct 10, 2024 - 20:43 EDT
Investigating
Our technical team are currently investigating reports of degraded performance occurring with ezyVet in the USW2 region

We apologize for the inconvenience this is causing – we will provide an update as soon as we have more information.
Posted Oct 10, 2024 - 20:38 EDT
This incident affected: ezyVet Software (ezyVet Software: USA and Canada West).