Vello Inbox & Vello Settings Unavailable

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Sep 04, 2025 - 18:58 EDT

Monitoring

A fix has been implemented and Vello Inbox and Vello Settings are available. We'll continue to monitor traffic to ensure full resolution.

There was no impact to pet owner portal/mobile app. All message history was retained -- text messages sent by pet owners during this time are available in the Vello Inbox.
Posted Sep 04, 2025 - 15:58 EDT

Identified

We have identified the issue and are working on a fix.
Posted Sep 04, 2025 - 15:49 EDT

Investigating

We are currently investigating an issue with accessing Vello.

At present the Vello Inbox and Vello Settings are unavailable. There is no impact to the pet owner portal/app.
Posted Sep 04, 2025 - 15:38 EDT
This incident affected: Vello (Neo Vello, ezyVet Vello, Cornerstone Vello).