Delay In-House Ordering Requests Through VetConnect Plus and Cloud PIMS

Scheduled for May 3, 07:30 - 08:00 EDT

Update

We will be undergoing scheduled maintenance during this time.
Posted May 01, 2026 - 16:08 EDT

Update

We will be undergoing scheduled maintenance during this time.
Posted May 01, 2026 - 16:07 EDT

Scheduled

Our team is scheduling a planned security maintenance between 7:30am-8am ET where the system will be down for 5minutes.

You may experience a delay when submitting an IDEXX In House Diagnostic (IHD) Order within your Practice Information Management Software.

As always, IDEXX appreciates both your business and your patience. We apologize for the current interruption in the ability to order IDEXX In House Diagnostics and for any inconvenience this may cause.
Posted May 01, 2026 - 16:05 EDT
This scheduled maintenance affects: VetConnect PLUS (Ordering - In House Diagnostics).