VetMedStat, VMS Pro, VMS Admin degradation in preformance

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Apr 10, 2026 - 15:30 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 10, 2026 - 13:48 EDT

Investigating

We’re investigating reports of system lag and errors affecting VetMedStat, VMS Pro, and VMS Admin. Thank you for your patience as we work to restore full performance.
Posted Apr 10, 2026 - 12:33 EDT
This incident affected: Telemedicine (VetMedStat, VMS Pro, VMS Admin).