AWS has advised that the issue is now resolved on their end. Everything is looking good with all of the Telemedicine applications, so we are going to close out this incident. We will continue to monitor the system to make sure everything is working as expected.
Posted Oct 20, 2025 - 19:09 EDT
Monitoring
AWS has made tremendous strides and have implemented a fix but are not quite at full capacity. Things are looking much better on our end, but we should still anticipate the potential for sporadic issues until they are fully online. We will continue to monitor our applications until that happens.
Posted Oct 20, 2025 - 18:07 EDT
Investigating
We are experiencing degraded performance across our Telemedicine applications due issues with AWS. While they continue to work through things on their end, we will continue to monitor and support whatever we can on our end. We will send out updates as we get more information.