Self-service upgrade scheduling in MyCornerstone has been restored. Practice users can complete Schedule in the upgrade wizard again.
If you were unable to book an upgrade earlier today, please retry in MyCornerstone. Contact Cornerstone Support if you still need help.
Posted Aug 13, 2026 - 17:26 EDT
Update
A fix for self-service upgrade scheduling in MyCornerstone has been identified and is planned for deployment at 5:00 p.m. Eastern today.
After the deployment, practice users should be able to complete Schedule in the upgrade wizard. If scheduling still fails, please contact Cornerstone Support.
Until then, Cornerstone Support can still complete an upgrade schedule on your behalf.
Posted Aug 13, 2026 - 16:33 EDT
Identified
We are aware of an issue affecting some practices that use MyCornerstone to schedule a Cornerstone upgrade.
At this time, practice users may not be able to finish scheduling an upgrade in MyCornerstone. Earlier steps in the upgrade wizard can complete, but selecting Schedule may fail and the upgrade is not booked. Refreshing or retrying from a standard practice account will not resolve this.
If you need to schedule an upgrade, please contact Cornerstone Support. An IDEXX representative can complete the schedule on your behalf while this is being addressed.
Separately, some practices may also be unable to manage MyCornerstone users (including assigning a Practice Admin). Until this is resolved. Cornerstone Support can assist with those changes as well.
Our teams are actively working on a fix. We will update this page when service is restored.
Posted Aug 13, 2026 - 13:07 EDT
This incident affected: Cornerstone (MyCornerstone).