ezyVet Integration Issue- Cubex - Outgoing transactions stuck in Processing status
Incident Report for IDEXX Software
Resolved
This issue has been resolved and the monitoring period has successfully passed. We are confident that this issue is now resolved.

Our technical team have released a final update today to move any outgoing Cubex events impacted by this issue to a failed status. These will show with the error message "Could not complete sync in the maximum time of 10 minutes". If you still require any of these events to be sent to your Cubex cabinet you can bulk retry the events from your Dashboard>dispense cabinets tab.

Thank you for your patience as we worked through resolving this issue.
Posted Sep 06, 2024 - 02:03 EDT
Monitoring
We appreciate your patience as our technical team has been working to resolve this issue.

Our team have now released a fix to prevent any new Cubex events from remaining stuck in a processing state moving forward. This means new outgoing events will be sent to Cubex as expected. We will monitor this solution over the next day to ensure the issue is fully resolved.

Our technical team will now turn their focus to addressing the past events currently stuck in a processing state.

Please contact ezyVet support if you continue to experience problems with new Cubex events on your site moving forward.
Posted Sep 05, 2024 - 03:36 EDT
Identified
Thank you for your patience while our team investigated this issue.

Our team has identified the root cause and are currently working through options to resolve this issue.

In the meantime, we recommend billing from ezyVet as normal and manually withdrawing the relevant medication from the Cubex Cabinet.
Posted Sep 04, 2024 - 21:15 EDT
Update
We are continuing to investigate the issue impacting outgoing transactions from the Cubex integration leading to them being stuck in a "Processing" state.

In the meantime, we recommend billing from ezyVet as normal and manually withdrawing the relevant medication from the Cubex Cabinet.

If you are affected by this issue, please reach out to ezyVet Support and lodge a ticket so we can keep you updated directly.
Posted Sep 03, 2024 - 22:32 EDT
Investigating
We are currently investigating an issue that is impacting the outgoing transactions in the Cubex integration which may show them as being in a "Processing" status.
Posted Aug 30, 2024 - 12:31 EDT
This incident affected: ezyVet Third Party Integrations (Cubex).