Supplier integration - NVS is currently unavailable

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Oct 07, 2025 - 06:16 EDT

Investigating

We are currently working with the team at NVS to identify the cause of the issue.
Posted Oct 06, 2025 - 11:00 EDT
This incident affected: ezyVet Third Party Integrations (Product supplier Integrations).