Heska Imaging Integration Issue

Incident Report for IDEXX Software

Resolved

This issue has been resolved and the monitoring period has successfully passed. All systems are back to operational levels and functioning as expected.

Thank you for your patience as we worked through resolving this issue.
Posted Apr 08, 2025 - 10:59 EDT

Identified

Heska Imaging, one of our third-party integrations, is currently experiencing an issue with connectivity. This is affecting the ability to order diagnostic imaging in ezyVet. Please contact Heska Imaging directly for further details.
Posted Apr 07, 2025 - 12:23 EDT
This incident affected: ezyVet Third Party Integrations (PACS Medical Imaging integrations).