Potential Delay in inVue Blood Dx Results

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Mar 05, 2026 - 14:30 EST

Monitoring

We experienced a temporary degradation affecting inVue Dx Blood result processing, which may have caused delays. The issue is actively resolving.

Please continue to leave any active runs “In Process”—they will complete normally as the system stabilizes. Thank you for your patience, and we appreciate your partnership.
Posted Mar 05, 2026 - 14:23 EST