Vello: Degraded Performance - AWS Outage

Incident Report for IDEXX Software

Update

We have confirmed all Vello systems are fully operational today. While we work through a backlog of data to process, you will experience delays in write-backs to communications logs and updates to pet owner portals/accounts. At this time, there is no impact to automated client communications or 2-way texting with pet owners. We will continue to monitor the Vello systems closely.
Posted Oct 21, 2025 - 14:14 EDT

Monitoring

We continue to monitor Vello system recovery as an AWS outage has been resolved. During this time, you may still experience delays in communications and intermittent connectivity issues with Vello.
Posted Oct 20, 2025 - 19:51 EDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 06:38 EDT

Identified

Vello services are currently impacted by an AWS outage. During this time, practices and pet owners will experience intermittent connectivity and performance issues with Vello. Automated communications may be delayed. We will continue to monitor and respond to AWS recovery efforts.
Posted Oct 20, 2025 - 06:35 EDT
This incident affects: Vello (Neo Vello, ezyVet Vello, Cornerstone Vello, Pet Owner Portals, Texting Services).