Pet Health Network Pro: Communications Delayed

Incident Report for IDEXX Software

Resolved

This issue has been resolved. All communications have been sending as expected.
Posted May 28, 2025 - 17:44 EDT

Monitoring

We have patched a fix and are monitoring the system -- all communications are currently sending as expected.
Posted May 28, 2025 - 13:36 EDT

Identified

We are aware of and are actively remediating an issue with Pet Health Network Pro automated communications. While we work to implement a fix, expect communications to be delayed.

2-way texting, pet owner portals / apps, and settings portals are not impacted.
Posted May 28, 2025 - 10:39 EDT
This incident affected: Pet Health Network Pro (Pet Health Network Pro).