VetMedStat - Clinics experiencing errors while attempting to submit cases

Incident Report for IDEXX Software

Postmortem

Incident details/action items (upcoming) can be found here:
https://idexx-telemedicine.datadoghq.com/incidents/30

Posted Feb 27, 2026 - 05:41 EST

Resolved

Issue: 2-4:30am EST VetMedStat clinics experienced errors while attempting to submit cases.

At this time, VetMedStat is stable, clinics are able to submit cases without issue & this incident is in a monitor state.
Posted Feb 27, 2026 - 02:00 EST