Cornerstone Vello Delays in Data Processing

Incident Report for IDEXX Software

Resolved

The backlog of data has been processed and this issue has been resolved.
Posted Sep 12, 2025 - 09:49 EDT

Identified

We are currently experiencing delays in our Cornerstone data processing and are working to remediate the issue. No data have been lost.

Until fully resolved, a subset of appointment and medical service reminders will not include updates made to client and patient records since August 30.

We will provide updates on progress as available.
Posted Sep 05, 2025 - 14:10 EDT
This incident affected: Vello (Cornerstone Vello).