ezyVet Third Party Integration Issue

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Jul 24, 2025 - 05:46 EDT

Investigating

Heska Imaging, one of our third-party integrations, is currently experiencing an issue with SSL. This is affecting the ability to send diagnostic requests in ezyVet. Please contact Heska Imaging directly for further details.
Posted Jul 23, 2025 - 11:08 EDT
This incident affected: ezyVet Third Party Integrations (PACS Medical Imaging integrations).