Neo: Zoetis and Ellie Diagnostics Order Issues

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Nov 20, 2025 - 14:13 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 14, 2025 - 14:40 EST

Investigating

The Neo Team is aware of an issue with Zoetis Point-of-Care, Zoetis Reference Labs, and Ellie Diagnostics that is causing orders to intermittently fail. We are actively working to resolve this issue as soon as possible.

Until the issue is resolved, to ensure all diagnostic orders are successful and avoid duplicate orders, we recommend you place orders directly with the applicable lab.

You will be able to reconcile results from the Diagnostics Orders and Results page when they are available in Neo.

Reminder: You can add the diagnostic product to the consultation for billing purposes and then close the consultation without waiting for the result to be ready for reconciling.

Thank you for your patience.
Posted Nov 14, 2025 - 14:39 EST
This incident affected: Neo (Third Party Integrations).