DataPoint - Excessive delays in sync processing

Incident Report for IDEXX Software

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 09, 2026 - 13:21 EDT

Investigating

We are experiencing a temporary delay in our batch sync process, which may cause slower data updates for some sites.
Posted Apr 09, 2026 - 11:13 EDT
This incident affects: DataPoint (DataPoint-API).