Neo Client Page Errors

Incident Report for IDEXX Software

Resolved

The fix has been applied for customers in the Asia-Pacific region and this incident is now resolved.
Posted Jun 10, 2025 - 09:08 EDT

Identified

We have identified the cause of the problem and a fix has been applied for our North American customers. We are working on applying that same fix for our Asia-Pacific customers.
Posted Jun 10, 2025 - 08:57 EDT

Investigating

We are currently investigating an issue causing errors on Client pages.
Posted Jun 10, 2025 - 08:16 EDT
This incident affected: Neo (Neo Software).