EzyVet Performance Issue - EUW1

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Sep 11, 2025 - 05:01 EDT

Monitoring

Our technical team have applied a fix to resolve this issue.

We will be monitoring this for the next 15 minutes to ensure the system is completely stabilized.
Posted Sep 11, 2025 - 04:45 EDT
This incident affected: ezyVet Software (ezyVet Software: Europe/Middle East/Africa).