IDEXX Web PACS Scheduled Maintenance

Scheduled for Apr 3, 20:00 - 23:00 EDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 01, 2025 - 15:49 EDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 03, 2025 - 20:00 EDT

Scheduled

IDEXX Web PACS will be undergoing maintenance on Thursday April 3, 2025 from 8pm ET to 11pm ET.

Users may be logged out of IDEXX Web PACS during the scheduled maintenance.
Posted Apr 01, 2025 - 15:45 EDT
This scheduled maintenance affects: Diagnostic Imaging (IDEXX Web PACS).