Planned Maintenance for VetConnect PLUS Ordering

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Oct 10, 2025 - 08:36 EDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 09, 2025 - 15:14 EDT

Identified

Our ordering service will be temporarily unavailable Thursday at 9:00 PM EST for approximately 10–15 minutes. We’re making improvements behind the scenes—thanks for your patience.
Posted Oct 09, 2025 - 14:55 EDT
This incident affected: VetConnect PLUS Ordering (VetConnect PLUS Ordering) and VetConnect PLUS (Web).