DVMI - Users are unable to create cases

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Apr 06, 2026 - 23:55 EDT

Monitoring

The system is currently stable. Will continue to monitor.
Posted Apr 06, 2026 - 23:42 EDT

Investigating

We are currently investigating this issue.
Posted Apr 06, 2026 - 23:35 EDT
This incident affected: Telemedicine (DVMInsight).