Cubex Integration Issue

Incident Report for IDEXX Software

Resolved

The Cubex Team has confirmed that this issue has now been resolved.
Posted Jun 11, 2026 - 00:00 EDT

Identified

The Cubex Team is still actively working to restore services for all affected sites.
Posted Jun 10, 2026 - 20:00 EDT

Update

The Cubex Team are still actively investigating the issue and working to restore full functionality as quickly as possible.
Posted Jun 10, 2026 - 17:30 EDT

Investigating

Cubex, one of our third-party integrations, is currently experiencing a service interruption affecting the integration. As a result, Patient, Profile, and Billing updates are being delayed and may not be processing as expected in ezyVet.
Posted Jun 10, 2026 - 15:00 EDT
This incident affected: ezyVet Third Party Integrations (Cubex).