The Azure incident is fully resolved and Vello is fully functional for Cornerstone customers. We will continue with regular system monitoring.
Posted Oct 29, 2025 - 21:14 EDT
Update
Azure continues to recover steadily, we continue to monitor the progress and impact to Cornerstone Vello. Customers will continue to see intermittent connectivity issues and delays in data syncing at this time.
Posted Oct 29, 2025 - 19:17 EDT
Update
Cornerstone Vello customers are experiencing additional degraded service due to the Azure outage -- including appointment booking, settings access, and communication write-backs to client/patient records.
We are aware of an issue impacting Cornerstone practices ability to access Vello Settings via MyCornerstone. We are monitoring progress on the related Azure outage here: https://azure.status.microsoft/en-us/status
Vello Inbox, automated communications, and pet owner portal/app are not impacted.
Posted Oct 29, 2025 - 12:45 EDT
This incident affected: Vello (Cornerstone Vello).