ezyVet Asteris/Keystone Integration Issue

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 09:01 EDT

Investigating

Asteris/Keystone, one of our third-party integrations, is currently experiencing an issue which is affecting the ability to make imaging diagnostic requests in ezyVet. Please contact Asteris/Keystone directly for further details.
Posted Apr 07, 2026 - 08:44 EDT
This incident affected: Diagnostic Imaging (PIMS Ordering).