Antech - Third party cloud services Outage

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 11:05 EST

Investigating

Antech, our third party partner, is currently experiencing an issue with their third party cloud services. This is affecting the ability to create diagnostic requests from Antech in ezyVet.

Please contact Antech directly for further details, their contact information can be found on the Contact Antech page.
Posted Nov 18, 2025 - 08:43 EST
This incident affected: ezyVet Third Party Integrations (Diagnostic Integrations).