VetMedStat: Users unable to DICOM send -- WebPACS/VC+: Delays in report visibility

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Mar 06, 2026 - 08:24 EST

Monitoring

The issue has been identified, a fix has been implemented and we are monitoring the results.
Posted Mar 06, 2026 - 01:06 EST

Update

Investigation is ongoing.
Next Update: TBD.
Posted Mar 05, 2026 - 23:47 EST

Investigating

Issue: Users are currently experiencing issues when DICOM sending to VetMedStat. Multiple WebPACS users have reported results are missing results in VC+ and respective PIMS .We apologize for any inconvenience. Investigations are ongoing.

Group(s) Impacted: VetMedStat & WebPACS clinics

Estimated Time to Resolution: TBD

Estimated Next Update Time: 30m (11:45pm EST)
Posted Mar 05, 2026 - 23:15 EST
This incident affected: Telemedicine (VetMedStat) and Diagnostic Imaging (IDEXX Web PACS).