We are continuing to investigate reports of this issue. Until it is resolved, please use Empty Cache and Hard Reload as needed.
Posted Jul 16, 2026 - 16:39 EDT
Monitoring
A fix has been applied and we're monitoring the system.
Posted Jul 16, 2026 - 13:31 EDT
Identified
The Neo team is aware of an issue impacting IDEXX Payments transactions. We are working with our IDEXX Payments partners to understand the root cause.
In Google Chrome, please Empty Cache and Hard Reload to resolve the issue.
Mac - Open the page you want to refresh. - Open Chrome DevTools using Command (⌘) + Option + I. - With DevTools open, click and hold or right-click the Reload button beside the address bar. - Select Empty Cache and Hard Reload. Windows - Open the page you want to refresh. - Open Chrome DevTools using Ctrl + Shift + I or F12. - With DevTools open, click and hold or right-click the Reload button beside the address bar. - Select Empty Cache and Hard Reload.