Mass Communications in Vello not sending to Microsoft email addresses

Incident Report for IDEXX Software

Resolved

This incident is now resolved. However, we continue to monitor our email deliverability closely.
Posted Jan 27, 2026 - 14:58 EST

Monitoring

We have identified the root cause and are continuing to apply fixes and improvements. We are monitoring the system closely.
Posted Jan 14, 2026 - 17:31 EST

Investigating

We are currently investigating an issue where Vello Mass Communication emails are not sending to Microsoft email addresses (@live.com, @outlook.com, etc.). Other transactional emails such as reminders are still sending appropriately.
Posted Dec 23, 2025 - 11:50 EST
This incident affected: Vello (Neo Vello, ezyVet Vello, Cornerstone Vello).