VetConnect PLUS Imaging Delay

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Apr 08, 2026 - 13:19 EDT

Identified

We appreciate your patience while we fix an issue that may temporarily delay the display of new Diagnostic Imaging results. We hope to resolve the issue as quickly as possible and apologize for any inconvenience. To receive email notifications for service updates, visit status.idexxsoftware.com and subscribe to VetConnect PLUS updates.
Posted Apr 08, 2026 - 11:05 EDT
This incident affected: VetConnect PLUS (Diagnostic Results, Web, Mobile).