USE1 Performance Outage 02/09/2025 08:40AM EDT

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Sep 02, 2025 - 09:31 EDT

Monitoring

We have identified the issue and actioned a fix. We will continue monitoring the performance.
Posted Sep 02, 2025 - 09:19 EDT

Investigating

We are currently investigating reports of an outage on the USE1 Database.
Updates will be posted here when they become available.
Posted Sep 02, 2025 - 08:59 EDT
This incident affected: ezyVet Software (ezyVet Software: USA and Canada Central/East).