ezyVet Performance Issue EUW1

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Oct 09, 2025 - 04:02 EDT

Monitoring

Our technical team are currently investigating reports of degraded performance occurring with ezyVet in the EUW1 region

We apologize for the inconvenience this is causing – we will provide an update as soon as we have more information.
Posted Oct 09, 2025 - 03:45 EDT
This incident affected: DataPoint (DataPoint-API) and ezyVet Software (ezyVet Software: Europe/Middle East/Africa).