Petly Plans Disruption for Azure Outage

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 21:08 EDT

Identified

We are aware of an issue with Petly Plans syncing of client/patient data from Cornerstone related to the Azure outage. We are closely monitoring the here: https://azure.status.microsoft/en-us/status. We will continue to monitor Petly Plans through full Azure recovery.

All other aspects of Petly Plans remain fully functional.
Posted Oct 29, 2025 - 15:49 EDT
This incident affected: Petly Plans (Petly Plans, PIMS Data Integration Service).