Neo Cloud Print Errors

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Apr 25, 2025 - 22:06 EDT

Investigating

The Neo team is investigating reports of errors that started occurring at ~7:15PM ET when printing via Neo Cloud Print.

Until the issue is resolved, print locally.

We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Apr 25, 2025 - 19:41 EDT
This incident affected: Neo (Neo Software).