ezyVet Performance Issue in USE1, USE2, USW2, APSE1, APSE2, EUW1

Incident Report for IDEXX Software

Resolved

Based on our monitoring and an update from AWS (https://health.aws.amazon.com/health/status), this issue has been resolved. You should now be able to access your ezyVet site.
Posted Feb 10, 2026 - 17:46 EST

Monitoring

AWS have implemented a fix, we are continuing to monitor stability on our side. More information can be found via https://health.aws.amazon.com/health/status
Posted Feb 10, 2026 - 17:02 EST

Identified

This issue has been identified as an AWS issue. More information can be found via https://health.aws.amazon.com/health/status. We will continue to monitor and are exploring possibilities to work around the issue.
Posted Feb 10, 2026 - 16:29 EST

Update

We are continuing to investigate this issue.
Posted Feb 10, 2026 - 16:04 EST

Update

We are continuing to investigate this issue.
Posted Feb 10, 2026 - 16:01 EST

Investigating

We are currently investigating this issue
Posted Feb 10, 2026 - 15:49 EST
This incident affected: ezyVet Software (ezyVet Software: USA and Canada West, ezyVet Software: USA and Canada Central/East, ezyVet Software: Australia, ezyVet Software: New Zealand, ezyVet Software: Asia, ezyVet Software: Europe/Middle East/Africa).