PowerScribe One - Users unable to connect to speech services

Incident Report for IDEXX Software

Update

Microsoft has temporarily redirected some speech operations from the primary server to a secondary server. The RADIXX team was able to confirm that users can access speech services, but not everything is back to normal and some issues were detected. We will continue to update this incident with any news from Microsoft (Nuance).
Posted Mar 23, 2026 - 15:44 EDT

Update

The RADIXX team has ruled out any possible issues with our applications. An elevation has been created with Nuance (Microsoft). We will let you know once we hear back from them.
Posted Mar 23, 2026 - 13:30 EDT

Investigating

Users are unable to connect to speech services in PowerScribe One. Issue is being investigated.
Posted Mar 23, 2026 - 13:13 EDT
This incident affects: Telemedicine (PowerScribe One).