Some users unable to load Vello integration settings in ezyVet

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted May 19, 2026 - 16:57 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 19, 2026 - 16:25 EDT

Identified

Service has been restored for the majority of affected users. The team has identified the root cause and is applying a fix to the remaining instances.
Posted May 19, 2026 - 16:11 EDT

Investigating

We are investigating reports that the Vello integration configuration screen is failing to load for a small number of customers within ezyVet.
Other Vello functionality is unaffected at this time. We will provide an update as soon as we have more information.
Posted May 19, 2026 - 14:34 EDT
This incident affected: Vello (ezyVet Vello).