ezyVet/ Vet Radar/ Smartflow support phone system technical issue
Incident Report for IDEXX Software
Resolved
This issue has been resolved. All systems are back to operational levels and functioning as expected.

Thank you for your patience as we worked through resolving this issue.
Posted Nov 17, 2024 - 16:04 EST
Investigating
We are currently experiencing technical problems with our support phone system, which are preventing customers from reaching our team. We appreciate your patience while we work with our third-party provider to resolve the issue.

If you require support in the meantime, please raise a ticket via the support widget in your application or email us directly at feedback@ezyvet.com or smartflow@idexx.com. Our team will respond as quickly as possible.

Thank you for your understanding, and we apologize for any inconvenience this may cause.
Posted Nov 17, 2024 - 14:21 EST
This incident affected: ezyVet Third Party Integrations (ezyVet/ Vet Radar/ Smartflow Support Phone System).