VMS and Web PACs slowness

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Jul 28, 2026 - 19:24 EDT

Monitoring

A fix has been made. You should be able to view images again. We will continue to monitor.
Posted Jul 28, 2026 - 18:19 EDT

Investigating

We are actively investigating an issue with Image Manager (Web PACS) that is impacting the VMS application.

Expected Impact:
Slowness across both systems.
Intermittent errors when viewing images.
Total login or access failure for some users.

We are working to resolve this as quickly as possible
Posted Jul 28, 2026 - 18:11 EDT
This incident affected: Telemedicine (VetMedStat, VMS Pro, VMS Admin) and Diagnostic Imaging (IDEXX Web PACS, Diagnostic Images).