Vello Practice App Not Accessible

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Nov 17, 2025 - 11:52 EST

Investigating

We are aware of and are actively investigating an issue affecting access to Vello Practice Settings and Vello Practice Inbox.

Vello pet owner portal/mobile app is not affected. Automated reminders are sending as scheduled.

We will update this page as we work to resolve the issue and as new information becomes available.
Posted Nov 17, 2025 - 11:42 EST
This incident affected: Vello (Neo Vello, ezyVet Vello, Cornerstone Vello).