Petly Plans: Degraded Performance / AWS Outage

Incident Report for IDEXX Software

Resolved

Petly Plans has fully recovered from an AWS outage. All pending processes (monthly payments processing, plan renewals, etc.) have successfully completed. We will proceed with standard system monitoring to ensure all continues to operate as expected.
Posted Oct 20, 2025 - 19:49 EDT

Identified

Petly Plans is currently experiencing degraded service due to an AWS outage. Practices may see delays in monthly payments processing, plan renewals and similar activities. We continue to closely monitor updates from AWS to ensure Petly Plans responds as expected.
Posted Oct 20, 2025 - 11:23 EDT
This incident affected: Petly Plans (Petly Plans).