Delay in results processing for VetConnect PLUS

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 13:30 EDT

Investigating

We are currently investigating an issue with our Google cloud provider.
Posted Sep 01, 2026 - 11:41 EDT
This incident affected: VetConnect PLUS (Diagnostic Results, Web, Mobile).