DataPoint Appointment creation - 11/19/25

Incident Report for IDEXX Software

Resolved

On 11/18/25, DataPoint implemented security updates. These changes resulted in errors when specific fields were omitted from requests. The security update has since been reverted.
Posted Nov 19, 2025 - 12:57 EST

Investigating

We are aware of and are actively investigating an issue affecting DataPoint appointment creation that maybe impacting some customers

We will update this page as we work to resolve the issue and as new information becomes available.
Posted Nov 19, 2025 - 12:19 EST
This incident affected: DataPoint (DataPoint-API).