ezyVet Performance Issue - Medication List Loading Slow in Patient/Clinical Tab (ALL REGIONS)

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 17:09 EST

Identified

Our Technical Team are currently investigating reports of Degraded Performance where Medication Lists are Loading Slow in Patient/Clinical Tab for ALL Regions.

We apologize for the inconvenience this is causing – we will provide an update as soon as we have more information.
Posted Feb 24, 2026 - 15:16 EST
This incident affected: ezyVet Software (ezyVet Software: USA and Canada West, ezyVet Software: USA and Canada Central/East, ezyVet Software: Australia, ezyVet Software: New Zealand, ezyVet Software: Asia, ezyVet Software: Europe/Middle East/Africa).