ezyVet - SMS Issue affecting customers in the United States and Canada

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Jul 29, 2025 - 07:19 EDT

Identified

Thank you for your continued patience while we continue working on this issue.

Our team is making progress towards a resolution to restore SMS services and continues to work on this with urgency. We acknowledge the disruption this is causing to normal communication workflows for our customers and continue to recommend using alternative communication methods at this time.

We will share further updates as soon as we have new information available or within the next 24hrs.
Posted Jul 28, 2025 - 23:30 EDT

Update

We appreciate your ongoing patience. Our team continues to investigate with urgency and is actively working with our third-party SMS provider to resolve this issue.

Customers in the USA and Canada are encouraged to continue using an alternative method of communication, such as e-mail, in the meantime.

We will share any updates as soon as we have new information available or within the next 24hrs.
Posted Jul 28, 2025 - 00:46 EDT

Investigating

Our technical team have identified an issue relating to our third-party SMS provider Twilio and are currently investigating. This issue appears to be impacting customers in the USA and Canada, causing SMS communications sent from ezyVet to fail. We are currently working to understand the problem further and diagnose the cause. As we have further information available, we will provide additional updates. In the meantime, we would recommend using an alternative method of communication such as e-mail.

We appreciate your patience while we investigate.
Posted Jul 27, 2025 - 09:00 EDT
This incident affected: ezyVet Third Party Integrations (SMS Providers).