Issue viewing diagnostics results from the patient Results tab in Neo

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Jan 15, 2026 - 18:02 EST

Update

A fix is rolling out to all customers.

We'll provide another update once the fix is fully released.
Posted Jan 15, 2026 - 17:00 EST

Identified

The Neo team is aware of an issue impacting some customers when viewing diagnostic results from the patient Results tab.

Until the issue is resolved:
- View diagnostic results from the Diagnostic Orders and Results page
- View results directly in VetConnect PLUS

We are working on a fix and will provide another update no later than 5:00PM ET, January 15.
Posted Jan 15, 2026 - 10:54 EST
This incident affected: Neo (Neo Software).